Manage My Account

Common Questions & Answers

What version of Internet Explorer do I need?

Although older versions of Internet Explorer (IE) will function with our program, we do not actively support versions older than IE 8 (released in 2009).  This is for security reasons and it is suggested that you update your browser to the latest available version.

 

Watch the Help Video:

Video troubleshooting for Internet Explorer.

 


Contact Customer Support

Click on 'Live Help' to talk with us online (8:00am - 5:00pm, CST)

Or email us directly at: help@legalconference.com.

Please feel free to phone our offices between 8:00am - 5:00pm, CST at
1-800-529-5121.